HDMI no signal on output modes other then 1080p

Oscar Myer

New member
I'm not the most technically inclined, and I don't know what information would be important or not, so forgive me if I ramble. My Dreamcast will not display an image through the DC Digital (firmware version 4.9 in standard) when booting up in 960p mode. This issue happens almost every time. This also happens in VGA and 480p modes, though I cannot replicate the behavior in 1080p mode.

When there is nothing on screen, changing the output resolution will instantly fix the issue, and 960p can be re-selected and work as intended until the next time the console is power cycled. This can also be done by holding down on the d-pad while the console boots up.

Also, while the DC Digital is not displaying anything, the test data screen from the web console will show X’s across the board, and the LED on the board itself will be blinking rapidly. Using the command “resetfpga” from the web console will instantly fix the issue, as will “generate_on”, which will display the test screen, and will cause the DC Digital to display normally after turning the test screen off. “resetpll” didn’t do anything, if that matters. I also used the web console to cleanup and re-flash everything, but the problem persists.

My Dreamcast is using the DC Mini BCU replacement power supply from Behar Bros. Replacing that with the original power supply seemed to work at first, but powering on after leaving the console off for a while resulted in no signal and an LED off. I was unable to get a signal or LED from the DC Digital after this point using the original power supply, though admittedly I didn’t try for too long. Plugging the replacement power supply back in, it seemed to take a bit longer for the LED to do anything, but it did come on and everything worked as expected on the first attempt, before the problems returned after leaving the console off for a while.

I then tried using a different Mini BCU, which also failed to fix the problem. Power cycling the console repeatedly resulted in an image occasionally, more frequently the more you do it until it starts to work every time. Letting the console sit turned off for a while will cause the issues to come back.

The Dreamcast is also using a real GDEMU, though for a good chunk of testing it was removed so I could access the web console. As an aside, no matter where the antenna was positioned, I was unable to get a wifi signal while the GDEMU was plugged in. I noticed on the github page the wifi results with the new antenna placement where measured with a GDEMU clone, so I thought I might mention that. I should also mention that the GDEMU is not connected to the DC Digital.

As for things that I have not done, I have not checked the flex cable or any of the connections, though I suppose that would be the next step. I did not install the board myself, and would be unable to work on it if there is an issue with the connections.

Sorry for the wall of text. Any insight would be welcome, and I appreciate your time.