GCLoader "An Error Has Occurred" (red box of death)

elgarlic

New member
Hello,

I ordered my GCLoader from black-dog a couple of months ago. It worked great. And I also tested my gamecube, of which I am the original owner, extensively after taking it out of storage but before installing the mod. Swiss booted, games loaded, no problems.

I do not recall the firmware it shipped with, but I know from what others have said that it's outdated. Swiss has a nag screen to update, and yesterday I did so, to 1.1.2 (using https://gc-loader.com/firmware-updates/). Booted the DOL, updated the firmware, got the all clear to power off and on. After doing so, I get the "An Error has Occurred" as the gamecube boot intro lingers on the screen. Previously, Swiss would load in a half second, as it should.

Accessing any other part of the GC bios menu still ends up with the red text box by the time the gamecube tries to read the 'disc'. I am using the laserbear mount, but the error is independent of SDs being inserted or not. I could boot into Swiss 100% of the time before the update. Strangely, I did manage to boot once after updating, (maybe the 12th time?). But it was not reproducible after many continued attempts. If I manage to do so again, is it safe to downgrade firmware? Or should I be considering anything else to fix this? Thank you
 

elgarlic

New member
Update: Twice, out of dozens of attempts, the console has booted into Swiss. Both times, the console had been off (and unplugged) for 1 hour or overnight.

The second time, I downgraded the firmware to 1.1.0, and now everything is working fine again. Of course, I am wary about attempting to upgrade again.
 
Top