ESD Issue, no analog video after install

Hi all -

I completed my DCDigital install a few days ago, and I've been experiencing a few strange issues. Hopefully someone is able to help me out.

Firstly, I am experiencing an odd ESD issue. I have a camp chair set up between 3 and 4 feet away from my 50" Samsung that I like to sit in when I game. The chair material and metal legs can cause a small static shock when standing up, which isn't really painful or a big deal. However, I have noticed that when playing my Dreamcast, standing up and the resulting static shock actually causes the Dreamcast to reboot! It doesn't matter if I'm holding the controller or not; in fact, it will even occur when no controllers are connected at all. Here's a vid showing what happens - the only things plugged into the Dreamcast are the OEM power cable and a 6 foot mini HDMI cable. It also seems to be a "soft" reset; if the DCDigital OSD is open when the reset occurs, it will be open when the Dreamcast reboots. I have noticed that the rebooting only occurs when the mini HDMI cable is plugged in to the Dreamcast, if that narrows down the cause. Potential causes that I can figure: lack of shielding, bad mini HDMI cable, PSU needs to be recapped? Maybe the ground connection requiring high heat is poor - can anyone suggest a good way to test it with a multimeter?

ESD Issue

Secondly, while troubleshooting the above, I discovered that the analog output no longer seems to work. I tested the console by playing a few rounds of Crazy Taxi before doing the install, and the composite cable worked fine. Now, I've tested on three different TVs, and don't seem to get a signal with Cable Select turned on. To troubleshoot this, I have checked the VCLK/CSYNC/HSYNC/VSYNC pins on the video DAC for bridging using a multimeter, and everything seems to check out. I have also tested the resistor pack RN4 and found no bridging. Lastly, I checked continuity between the through-hole solder points on the flex cable and pins 6 and 7 on the multi-out, and I have continuity there, too. Using HDMI, I do not see a visual difference between Force VGA and Cable Select. Is it possible that the switch isn't happening for some reason, despite the menu showing the correct selection?

Lastly, and least importantly, I am seeing a garbled logo when I cold boot the console, as seen in this video. It corrects itself, but I just find it odd.

Garbled Boot Logo

Additional details:
  • Dreamcast VA1 NTSC-U
  • All hearts on the Test/Info screen
  • DCDigital Firmware 4.8 (have tried both Standard and Relaxed flavors)
  • Only other mods are rechargeable console battery and healable fuse
  • Tried and cannot see LED on DCDigital - not sure how you are supposed to with the console assembled (edit - booted without GDROM drive and saw a solid blue glow. No signal due to unplugged optical drive, obviously)


Last edited:
So I ran some further tests - unplugging the FFC allows me to get analog output. I suspect that the Cable Select option is not working correctly. I will try reflowing some of the connections to see if I can get this working properly.
Well, I don't want to jinx it, but I think I fixed it. I reflowed all connections not connected to the audio/video DACs with a screwdriver tip. I think the main culprit in all of this was that massive glob on the ground connection; I had used a conical tip originally since it's such a tight spot, and I think it just didn't get hot enough and I laid a bunch of solder on top of a cold joint.

I booted it up and changed to cable select, and I've never been so excited to see interlacing in my life. Composite video is working again, and the ESD issue doesn't seem to happen anymore (knock on wood).